a lot of compilation errors

Dec 22, 2013 at 5:43 AM
Edited Dec 22, 2013 at 5:45 AM
Hi James,

I'm trying to build v8.net and get a lot of errors while compiling v8.net-proxy assemblies.
I'm trying 03423e328a5f changeset and current HEAD revision 18dea117791951bdf2903615e0d1a0863c2751fe of V8.
Which revision of V8 is the source code based on? I guess it's not the latest.

Alex
Coordinator
Dec 22, 2013 at 3:29 PM
You don't need to compile the proxy libraries if you just want to compile the C# code (just reuse the V8 and proxy DLLs). If you need to compile the proxy also (non-windows) then the source doesn't yet compile with the latest V8 build.

You'll have to use this version of the source I have for now: http://sdrv.ms/1ceirI6
and unzip here: V8.NET\Source\V8.NET-Proxy\V8\build

If you need it to compile with the latest version, there's an issue entry here that has more details: https://v8dotnet.codeplex.com/workitem/1291

Hope that helps.